You need a newer version of flash